File object is locked by another application error when trying to edit Menta file

Issue

Receive error stating that a Menta "File object is locked by another application" when trying to open it for editing.

Product Line

TAC Vista

Environment

  • TAC Vista
  • Menta

Cause

There are several potential causes of this error:

  1. The Menta (.mta) file is already open locally or on a remote machine.
  2. The current user does not have the appropriate authority to edit the file.
  3. Menta crashes while editing a file opened directly from the Server. Each subsequent attempt to launch the Menta editor from Workstation will result in this error.
  4. When a "standard" Menta file is being used and the user attempts to edit the Menta file locally. For more information about this scenario, please see Lessons Learned #4762.

Resolution

The following resolutions correspond to the causes listed above:

  1. If an instance of Menta already has the file open, whether on the local computer or on a remotely connected computer, then it must be closed before trying to open and edit that particular Menta file again.
  2. If the current Vista user has only "User" privileges or is otherwise limited from editing Menta then a user with the appropriate authority should log in to open the Menta file for editing.
  3. Shut down then restart Vista Server and Workstation if the error was caused by Menta crashing.
  4. See the link in Cause D above.