Issue
Is there a way to reset the Last Daily Archive time and Last Backup Time in an I/A Series R2 station? System clock was inadvertently set ahead now the daily archive and daily backup processes are not running.
Environment
I/A Series R2 ES and UNC stations
Cause
Computer system clock was inadvertently set ahead and not discovered for several days. After correcting the clock setting, the daily archives and daily backup of the station does not appear to be running. Both entries "Last Daily Archive" time and "Last Backup Time" show a future date and time
Resolution
There is no direct procedure for changing these time stamp entries in an I/A Series R2 station however, the time stamp entries can be edited in an XML copy of the station database.
The following procedure can be used to reset these date stamp entries in the station database.
- Open the Admin tool, log into LocalHost, select the running station and use the DB Admin to Save Runtime Db. This updates the current config.db file with any unsaved station information.
- When the save is complete, stop the running station.
- Still in the DB Admin screen of the Admin tool, select the server station and perform a convert local from db to xml.
- Locate the "backups" folder under the r2.301.532 folder then in that folder, locate the folder for the server station you are working on. Rename the backup.zip file in that folder to backup.save.zip.
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Using a text editor capable of editing very large text files, open the config.xml file for the server station and make the following changes:
- Search for "<LastBackupTime>" and change the date to a date in the past.
- Search for "<LastDailyArchive>" and change the date to a date in the past.
- Search for each occurrence of "<LastArchiveTimestamp>" and change the date to a date in the past. If your editor has the capability of doing a replace all, you might be able to replace a group of these entries all at the same time, especially if you just change the date and ignore the time.
- Save the edited xml file and close the editor.
- Save the current config.db file by renaming it with a different extension.
- Using the DB Admin function of the Admin Tool, convert the station's xml file back to db.
- Verify that the current computer time is correct.
- Verify that if there is a time sync service running in the computer, that it is using a reliable time server as its source of time and date.
- You can now use the Admin Tool to restart the edited server station.
- Open the server station in WorkPlace Pro, navigate to the TimeSyncService under Services and verify that if "clientEnabled" is True, there are no blank entries for any of the timeProtocolServer slots. All three entries must be filled in, even if you put the same server address or name in more than one of the three slots.
The backup and archive functions of the server station should now operate at the specified times.