Why was the Sarix API access denied?

Issue

Why was the Sarix API access denied?

Product Line

Pelco Cameras

Environment

Sarix cameras- Version 1.5.9 +

Cause

Information regarding the denial of API access is needed.

Resolution

For details please refer to the API access blocked entry in the Sarix Issues section.

Note: This will only affect Sarix with firmware version 1.5.9 or higher.
 
If your Sarix IP camera has denied API access, then change the Public View Access Level (within the Sarix web application) to Viewers and the Sarix API will be accessible again.