Performing software updates to storage pool on the NSM5200.

Issue

Performing software updates to storage pool on the NSM5200.

Product Line

Pelco Video Management

Environment

Endura NSM5200 - All versions

Endura Utilities- Version 2.0 and above

Cause

Information on how a NSM pool is updated.

Resolution

If updating an NSM5200 Storage Pool, use Endura Utilities v2.4.11 or greater and perform the software update on the NSM5200 Storage Pool Manager only.

Afterwards, the NSM Pool Manager will send the update to each member 1 at a time in the background. After each unit updates, it reboots and the Pool Manager will select another to update, and after all members have checked in and reported successful updates, the manager will apply the update to itself and reboot. This will cause manager failover to occur, and a new manager will be elected while the original manager is offline. After the original manager applies the update and comes back online, it will operate in member mode until such a time as the new manager goes offline for any reason.

Each NSM in the pool can take between 15 to 25 minutes to update. Since the update is done sequentially, updating a pool with the several NSM's can be a lengthy process. During this time all of your cameras will continue to record so long as the total Pool bitrate does not exceed 250 Megabits of incoming camera video/audio stream bitrate per active member (Pool members minus 1 that is updating at any given time); Load balancing the streams occurs as each member goes offline to install the update.