Will the new IM Sarix cameras work on Digital Sentry version 4.2?

Issue

Will the new IM Sarix cameras work on Digital Sentry version 4.2?

Product Line

Pelco Cameras, Pelco Video Management

Environment

  • Digital Sentry (6.8.2.22)  Database version 4.2
  • IM Sarix camera

Cause

Digital Sentry system need to be on version 7.0.24 or higher to support IM series Sarix cameras.

Resolution

No. To add an IM series Sarix camera to your Digital Sentry system, you will need to be on version 7.0.24 or higher.

Complete the following steps to download the current software.

  1. Go to Digital Sentry home page
  2. Scroll down to Digital Sentry assets section
  3. Click on Asset Type and choose Software
  4. Download the latest version of DS ControlPoint or DS Software Suite.

Related Articles:
Digital Sentry Supported Devices List: What Pelco/Third-Party IP cameras are supported on the Digital Sentry (DS) System?