Adding a ODBC data source to a DSSRV system configured in a distributed (DMS/VAU) environment.

Issue

The VAU is unable to connect to the DMS.

Product Line

Pelco Video Management

Environment

  • Digital Sentry
  • DSSRV Series
  • DS Enterprise
  • Distributed
  • VAU/DMS

Cause

DSSRV's installed as distributed systems do not have the ODBC data source pre configured.

Resolution

  1. On the DSSRV's configured as DMS or VAU(s), navigate to Start > Control Panel > Administrative Tools (or Control Panel > System and Security > Administrative Tools if configured for Category view.)
     
  2. Double-click Data Sources (ODBC) to open.
     
  3. Click on the System DSN tab.



     
  4. Click the Add... button. 
     
  5. Select SQL Server then click Finish.



     
  6. Fill in the "Name" = DigitalSENTRY
     
  7. Leave "Description:" blank.
     
  8. Click the dropdown arrow for "Server:" and look for the computer name of your DMS, if not located enter manually.
    Can use hostname or IP address but must include "\DS_MSSQLSERVER"
    Example: DMS1\DS_MSSQLSERVER or 10.10.10.10\DS_MSSQLSERVER



     
  9. When the hostname/IP address of the DMS has been entered, click Next.
     
  10. Click  "With Windows NT authentication using the network login ID."
     
  11. Checked the box  "Connect to SQL Server to obtain default settings for the additional configuration options."



     
  12. Click Next.
     
  13. Check the box  "Change the default database to :", click the dropdown arrow and select DigitalSENTRY (can also type in manually if needed).
     
  14. Check "ANSI quoted identifiers" and "ANSI nulls, paddings and warnings."



     
  15. Click Next.
     
  16. Check "Perform translation for character data".



     
  17. Click Finish.
     
  18. On "ODBC Microsoft SQL Server Setup" window, click the Test Data Source button.



     
  19. Verify  "TESTS COMPLETED SUCCESSFULLY" message is displayed.