How to configure Axis camera, version 7.10 thru 8.30.1, Primary stream, Secondary stream, and motion detection for use with VideoXpert.

Issue

This document provides information to be used as a guideline for configuring Axis cameras/encoders so that VideoXpert can use 2 video streams and motion detection.

Product Line

Pelco Video Management

Environment

VideoXpert Enterprise
VideoXpert Storage
VideoXpert Professional
Axis IP cameras version 7.10 thru 8.30.1

Cause

The system integrator/installer needs to configure Axis IP cameras correctly in order for VideoXpert to utilize “Primary” and “Secondary” stream viewing along with motion detection.

Resolution

The purpose of this guide is to explain the requirements the camera must meet and provide a general configuration guideline.  For specific questions regarding camera settings or functions, please refer to documentation provided by Axis or contact Axis technical support.  If the camera configuration is too complex or the features do not meet the requirements for the installation, please consult Pelco Technical Sales Engineering for guidance on replacing the cameras with appropriate Pelco models.
 
Axis implementation of their ONVIF driver does not report motion detection the same way that the native Axis driver does and is not compatible with the VideoXpert ONVIF driver.  The camera can, however, be configured to use Axis simple motion detection rather than the camera’s motion “App” and added to VideoXpert using the Axis driver (Vapix API).  The following items are required to be configured:
  1. “Primary” stream
  2. “Secondary” stream
  3. Motion detection
  4. Add camera to VideoXpert using the Axis driver
  5. Configure recording schedule
 

 
If the camera has already been added to the VideoXpert system, it must be removed before going through this process.
  1. Open the camera’s web interface, go to “Settings”, then select “Stream” and configure the following:
    • Resolution
    • Frame rate
    • Compression
    • Bit rate control
    • H.264 profile
  2. Select the “System” tab, then “Stream Profile
    1. If there are existing profiles, remove all of them.
  3. Add a new profile:
    1. Name it “VideoXpert0P
    2. Give it a description, such as “Primary Stream
    3. On the “Image” tab, all settings match the “Stream” settings previously set in step 1.
    4. On the “H.264” tab, make sure the GOP length, h.264 profile, and bit rate control are set correctly
    5. Click OK
  4. Add another profile
    1. Name it “VideoXpert0S
    2. Give it a description, such as “Secondary Stream
    3. On the “Image” tab, set the resolution to a low value
    4. Set the frame rate as desired, such as 5 or 10 frames per second
    5. On the “H.264” tab, set GOP length, h.264 profile, and bit rate control
      1. Since the resolution is lower for this profile, you should use a lower bitrate, like 1500kbps
    6. Click “OK
  5. Configure motion detection:
    1. Go to http://<camera’s ip>/operator/motionDetection.shtml
    2. Configure the motion window and sensitivity settings as required
    3. Use the “Activity” window to validate motion detection is working properly
    4. Refer to Pelco Knowledge Base article LL#19750 for reference
  6. After making a lot of configuration changes, it is not a bad idea to reboot the camera
  7. Add the camera to VideoXpert using Admin Portal, not VideoXpert Toolbox
    • Manually add the camera/encoder rather than automatically detecting
    • When adding the camera to the recorder, select the Axis driver
  8. Configure the VideoXpert record schedules
    • Refer to Pelco Knowledge Base article LL#19014 for reference
    • Since the camera is already added to the VXS, skip to step 7.
      • Either modify an existing schedule or create a new one as necessary
  9. Once configuration is complete, pull up the camera in OpsCenter to verify video streaming and motion recording is working satisfactorily.