Issue
Using Database Initialization to add a workstation to an existing system results in an error.
After inputting all required information on the Workstation dialog, the below error is seen and the Workstation is not initialized into the database.
"Failed to initialize workstation"
Environment
Continuum Cyberstation
BACnet Devices
Cause
Third-party (or our own) BACnet controllers are interfering with the creation of the workstation device object. The BACnet Device ID's are clashing.
All workstations require an ID. If you have a BACnet system, in the Device Node ID field, enter the BACnet ID for the workstation. (Each workstation requires a unique BACnet ID number.) It can be any unique ID number between 1 and 4194302.
Note: In a BACnet network, this ID is unique for workstations and controllers alike and is vendor-independent
Each BACnet Device (including the Continuum workstation's) must have a unique ID that does not conflict with any other device on the same BACnet network.
Resolution
You can identify BACnet Device ID's already used within the Continuum Database and then choose one that does not conflict.
- Create a Listview looking at Device class with a path type of AllPaths. As a minimum add the following columns; Name, InstanceId, NetworkId, NetworkNumber.
- Run the listview. The list it generates is all of the BACnet Devices defined within your Continuum Database.
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The last portion of the InstanceId (after the backslash) indicates that Devices BACnet Device ID.
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You will need to identify a free number that is not being used and change the Device Node ID value you were trying to use in the Workstation Configuration dialog window. With this new Device Node ID that is not conflicting, you should now be able to initialize your workstation successfully.