Issue
Cannot attach the Network interface to Lonmaker database when the Vista Server (Tacos) is started as a service. The error message is that the 'NIC interface is not connected'.
Product Line
TAC Vista
Environment
- Echelon Lonmaker 3.1
- Echelon Lonmaker 3.2
- TAC Vista (all versions)
Cause
When updating Lonmaker and Vista databases as applications, it is important that Lonmaker be started first. Failure to do so can result in issues like this when Vista is reconfigured to start as a service.
Resolution
To get Vista and Lonmaker running together:
- Stop the Vista service and unregister it.
- If using a Loytec interface, set the Loytec Legacy Driver to run as a service (click the Advanced tab in LConfig).
- Start Lonmaker and attach the correct network interface. Ensure that Lonmaker is online.
- Start Vista Server as an application.
- From Lonmaker open the System Plugin. In the TAC Network properties, check that the correct network interface is selected. Update the Vista database.
- Start Vista Workstation and check that everything is online.
- Stop Vista and Lonmaker.
- Reregister Vista as a service.
For details of these operations see Registering/Unregistering TAC Vista Server as a Windows service.
Also see section 16.3 of the TAC Vista Technical Manual.