Rules for Upgrading

Issue

Upgrading 

Product Line

SmartStruxure Solution

Environment

Example: 1.4.0.xxx site upgrading to 1.5.x.xxx or 1.6.1.xxx

Cause

Guidelines for upgrading to higher releases

Resolution

Non-Sequential Upgrades: Versions 1.9.1 and Newer

Starting in version 1.9.1, non-sequential upgrades can be performed from versions 1.5.XXX and newer. Please refer to the "Upgrading" section of the Release Notes for the software version you are upgrading to. The "Upgrading" section will direct you to prior release notes that you need to read through before upgrading and point out items with limited runtime compatibility during the upgrade process. 

NOTE: If upgrading a system at 1.5/1.6/1.7/1.8 with LON devices, please be aware that there are special steps that must be taken to prepare the database for upgrade. These steps can be found in the Release Notes as well. 

 


Sequential Upgrades: Versions 1.8.1 and Older

For versions 1.8.1 and older, the upgrade process is sequential. In other words 1.2.0, 1.3.0, 1.4.0, 1.4.0.4020, 1.5.0, 1.6.1
The upgrade process can be found in the System Upgrade Reference Guide.

The primary released versions were
1.0.0.161
1.1.0.362
1.2.0.767
1.3.0.938
1.3.0.10100 SP1
1.3.0.20011 SP2
1.4.0.4020
1.4.1.68
1.5.0.532
1.6.0.250 (RC)
1.6.1.5000
1.7.0.255 (RC)
1.7.1.89


The minimum upgrade path would be:
1.0.0.161 Official Release
1.1.0.362 Official Release
1.2.0.767 Official Release
1.2.0.2207
1.3.0.938 Official Release
1.3.0.10100
1.4.0.4020
1.4.1.68 Official Release
1.5.0.532 Official Release*
1.6.1.5000 Official Release
1.7.1.89 Official Release

*Note:I have found that at one site, the AS would not upgrade from 1.5.0.532 to 1.6.1.5000. Going to the 1.6 RC resolved the issue.

 

 

1. In order to upgrade to 1.5 the site must be at 1.4.0.4020 or higher. It is highly likely that there are some sites that are still running at 1.4.0.818, which was the original 1.4.0 release. Although this is not officially supported and will not be tested, it is likely to experience the same upgrade as one from 1.4.0.4020.

2. An upgrade from 1.4.0.4020 to 1.5 will NOT offer any runtime compatibility, while an upgrade from 1.4.1 to 1.5 will offer runtime compatibility. Consequently, for a site to maximize its operational status through the upgrade, we have two different upgrade scenarios as described below.

a. 1.4.0 to 1.5 – this process flow is designed to allow as much of the plant as possible to continue to operate through the entire upgrade. For the first three steps of the process the Enterprise Server will continue to aggregate the alarms from all of the 1.4.0 Automation Server. Once the halfway mark is reached the Enterprise Server can be upgraded and will begin to aggregate the alarms from the 1.5.0 Automation Server.

             i. Upgrade one WorkStation in order to be able to communicate directly to any of the 1.5 Automation Server that are upgraded in b below.

            ii. Upgrade 50% of the Automation Server

            iii. Upgrade Enterprise Server and all but one WorkStation

            iv. Upgrade the remaining Automation Server

            v. Upgrade the remaining WorkStation

b. 1.4.1 to 1.5 - In this process, we can take advantage of the support for runtime compatibility and the Enterprise Server will receive alarms from both the 1.4.1 and the 1.5 Automation Server.

            i. Upgrade Enterprise Server and all but one WorkStation which can be used to talk directly to unupgraded Automation Server if configuration changes are needed

            ii. Upgrade Automation Server

            iii. Upgrade final WorkStation
Note:

  • some sites have experienced issues with the ES restart after upgrade because of the .Net Framework 4.5 upgrade and port 80 usage. Adjusting this port to an available port resolves the problem.
  • The conversion log may indicate an upgrade warning similar to warning shown below, this warning can be safely ignored, and furthermore the upgrade program corrects the problem in the 1.5 database. 

         :02:11  WARNING:      Property PFE202_PF601.SI in (~/BACnet/Application/ELE/GRAPHIQUES/ECLUSES CD S4/PORTES_CE_S4) is not defined in the new system, skip           PFE202_PF601.SI.