Alarm view is not shown in webstation

Issue

Alarm view is not shown in webstation instead this or similar is shown

The following errors have occurred.
Please correct these errors and/or contact the system administrator.
An unexpected exception has occurred:
Index was outside the bounds of the array.
System.IndexOutOfRangeException
at TAC.WebStation.Modules.Alarms.AlarmViewTable.GetColumnData(Object[]
rowData, Int32 columnIndex)
at
TAC.WebStation.Modules.ViewTableBase.AddColumnsToQueryString(QueryString
queryString, Object[] rowData, Int32[] columns)
at
TAC.WebStation.Modules.Alarms.AlarmViewTable.CreatePropertiesCell(Object[]
rowData)
at TAC.WebStation.Modules.Alarms.AlarmViewTable.CreateAlarmRow(Object[]
rowData, Int32 rowIndex, Boolean isDisabledView)
at TAC.WebStation.Modules.Alarms.AlarmViewTable.CreateTable(Table table)
at TAC.WebStation.Modules.ViewTableBase.FillTable(Table otherTable)
at TAC.WebStation.Modules.Alarms.AlarmListPage.DataBind()
at TAC.WebStation.Modules.Alarms.AlarmListPage.Page_Load(Object sender,
EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean
includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


 

Product Line

TAC Vista

Environment

TAC Vista Webstation

TAC Vista Server

Cause

If "site" is checked in the $alarmcolumns object this happens. This is a known defect.

Resolution

1. Find $Alarmcolums in the root folder In workstation

2. Go to Properties and uncheck the site option