How to upload and display short/Long messages on SE8000 series Room Controllers using SBO via BACnet

Issue

Unable to write strings (messages) to the "Long Screen Message Text" and the "Short Screen Message Text" points on the SE8000 Room controller using an Automation Server (AS) through BACnet.

Product Line

SmartStruxure Solution, SmartStruxure Lite

Environment

SmartStruxure Lite

Multi Purpose Manager

SE8xxx Room controller
SE8000 Series
SER8300, SE8300, SE8350
Ex. Viconics branding VT8000 Series

Cause

SBO does not support ".csv" BACnet objects.

Resolution

Short Message:

The Short Message can be written to the SE8000 room controller by populating the "Location" Property with the message

 

Long Message:

The Long Message can be written to the SE8000 room controller by populating the "Description" Property with the message

The message however will not get displayed until the "Display Long Screen Message" has been activated.

Optional: you can also choose the color of the long message background by changing the "Long Message Background Color".

 


Discrepancy on the text written to the device, and the text shown on the device

In some cases when using non-English characters in the messages, the text on the SE8000 will not be rendered as expected. The issue is caused by SE8300 not conforming to BACnet standard in string encoding and decoding. The workaround is to set "BACnet string encoding" property of the device to "ISO 8859-1(Latin-1)", or other encoding the device supports.

SE8300 claims to support BACnet protocol revision 10, which requires the conforming devie to interpret Character Set 0 as UTF-8 string. In 1.9, SBO started to write to devices using Character Set 0 for unicode strings, but the SE8300 fails to decode it.
Setting the "BACnet string encoding" to Latin-1 for the devices fixes the problem.