Issue
When Reports are opened and the user selects a Report then tries to run the report, an error comes up that says “Server Failed to Initialize” and nothing happens.
Environment
I/NET Seven Site
Cause
error comes up that says “Server Failed to Initialize"
Resolution
There is a fix for this but an IT individual will need to be present or the user must have admin rights to do this.
- Shut down I/NET and Seven Reports.
- Go to Start, Run and type Regedit at the prompt.
- Go to Local_Machine, Software, Microsoft, MSSQL Server, Super Socket Net Lib.
- Expand this and there should be two folders listed in here, NP and TCP.
- Highlight the Super Socket Net Lib and a Protocol file appears.
- Right Click this file and modify it to display the Hex addresses in there and verify that one exists for NP and TCP.
Value data:
0000 74 00 63 00 70 00 00 00 t.c.p...
0008 6e 00 70 00 00 00 00 00 n.p.....
0010
Note: If you are not sure please contact an IT professional to assist you.