How to upgrade to to version 1.9.1 from a 1.5.0, 1.6.1 or 1.7.1 SBO system with LON devices

Issue

Do I need to upgrade my entire SBO system to 1.5.0.171xx, 1.6.2.12xxx or 1.7.2.111xx before upgrading to 1.9.1 if I have LON devices?

Can I upgrade directly to SBO 1.9.1 from 1.5.X, 1.6.X or 1.7.X?

Product Line

SmartStruxure Solution

Environment

SBO Workstation 1.5.0/1.6.1/1.7.1

SBO ES  1.5.0/1.6.1/1.7.1

SBO AS  1.5.0/1.6.1/1.7.1

SBO AS-P  1.7.1

Cause

In systems that have SBO servers that already are hosting LON devices based on LonWorks imported device templates (.XIF) or resource kits (.DRF), the servers need to be prepared before an upgrade from versions 1.5/1.6/1.7 to version 1.9.1. Even servers where device templates (.XIF) or resource kits (.DRF) are just imported, and no devices or network variables are created yet, the servers have to be prepared before the upgrade. 

Resolution

Please see section 9.2.3 of SBO 1.9.1 Release Notes.

Although it says "Steps to upgrade a 1.6.2/1.7.2 multi-server system" you don't have to upgrade the AS or ES etc, even if they run 1.6.1/1.7.1, it's only SBO Workstation that need to be hotfixed.


Links to the different Workstation hotfixes can be found here.

If there are no LON devices in the system, you may upgrade directly to 1.9.1 from 1.5.X/1.6.X/1.7.X