License activation stops at 80% or License Administrator crash

Issue

Two related issues are covered in this article

1. While attempting to activate a customer or demo license, the activation process stops at around 80%.

2. When clicking the "Diagnostics" tab in the License Administrator it crashes with a "System.DllNotFoundException" error.

System.DllNotFoundException: Enable to load DLL (Tac.Nsp.Archive.Licensing.Client.dll)

Product Line

SmartStruxure Solution

Environment

First detected in Windows 10

First detected with Microsoft Visual C++ Redistributable 2012 (VC++ 2012)

License Administrator

Cause

There can be two reasons why this happens

1. If the activation process stops at around 80%, but the License Administrator does not crash when the "Diagnostics" tab is selected, the license system needs to be completely reset.

2. If the activation process stops at around 80%, and the License Administrator crashes when the "Diagnostics" tab is selected, Microsoft Visual C++ components needs to be repaired.

 

Refer to solutions below depending on the issue detected.

Resolution

Solution 1: Resetting the license system

The process to reset the license server system is covered in WebHelp article 6003. In some cases a deeper reset can be required. For that, a tool called "SBO License Server Reset" can be obtained through technical support.

 

Solution 2: Repairing Microsoft Visual C++ components

Method 1

1. In Control Panel, click Uninstall a program in the Programs group.

2. In the programs list, locate Microsoft Visual C++ 2012 Redistributable (X64) - 11.0.61030 or Microsoft Visual C++ 2012 Redistributable (X86) - 11.0.61030, depending on your system architecture.

3. Right-click the entry name, and then click Change.

4. In the Modify Setup dialog box, click Repair.

5. After the repair process is completed, restart the computer if you are prompted to do this.

 

Method 2

1. Run the Modify Setup repair functionality for Microsoft Visual C++ Redistributable by starting the installer. VC++ installers

2. In the Modify Setup dialog box, click Repair.

3. After the repair process is completed, restart the computer if you are prompted to do this.