Duplicate Card Numbers in Accessxpert

Issue

When adding a duplicate card into Accessxpert, an error is generated.

Product Line

AccessXpert

Environment

Accessxpert

Hosted Instance (cloud)

Premise

Windows Server 2012

SQL 2012 R2

Version 2

Version 3

Cause

Existing customers who may have multiple Tenants using multiple card formats and Facility Codes run into the the problem where there are duplicate cards that may have been ordered or handled differently. In Accessxpert, when the card is added an error shows up indicating that the card is already assigned and cannot be added to another person. Card offsets can be introduced in order to ensure no overlapping card number values.

Resolution

In order to resolve this issue, the following steps need to be followed:

1. Create a new Card Format using the same Tenant Information

2. Add a card number offset, which is added to the original value. ie. a Card Offset of 1000 would make card 100 read as 10100.

 

3. Save and Close

4. Reboot the controller