Issue
In a Niagara R2 / DMS integration, a re-learn of the DMS database fails. The re-learn was done after some points were deleted in the DMS database. How can the re-learn succeed using the undocumented "learnNoPointAbortCount" parameter?
Environment
Niagara R2 (all versions)
DMS (all versions)
Cause
Maintenance work on an installed system where points were deleted from a DMS
Resolution
When the DMS driver is doing a learn points function, it is scanning through the DMS points using LOGPT which is an integer 1 – 250. It attempts to get point1, point2, …. to point250. If a point does not exist the DMS panel returns “NOPOINT”. The learnNoPointAbortCount property specifies the number of consecutive “NOPOINT” returns that will cause the learn points function to terminate early. If the DMS has been reloaded from a saved DMS database, points will have consecutive LOGPT numbers and there will not be any gaps. If points have been deleted and created, there may be gaps in the LOGPT assignments. To ensure all 250 points are scanned, set the learnNoPointAbortCount to 250. It will just take longer for the learn to complete.