Problems installing Webstation 5.1.4 on PCs running Internet Information Services (IIS) 7 or higher.

Issue

Problems installing Webstation 5.1.4 on PCs running Internet Information Services (IIS) 7 or higher. The installation appears to be OK but just before it finishes it "rolls back" to the beginning and webapps is not installed.

  • Installation problems - Webstation 5.1.4 on Windows 2008 server
  • Installation problems - Webstation 5.1.4 on Windows 7
  • Vista 5.1.4 webapps software crashing during install

Product Line

TAC Vista

Environment

Windows 2008 server

Windows 7 (not officially supported)

Vista webapps (webstation)

Cause

This issue is caused due to compatibility issues with IIS 7. Vista 5.1.5 is compatible with IIS 7. Vista 5.1.4. is not compatible with IIS 7.

Resolution

In order to install TAC Vista Webstation successfully on Windows Server 2008 it has to be done in the following order:

Note : Make sure all installation is done as an administrator (Right click the file/application and select "Run as administrator")!

1. Install IIS 7 with IIS 6 Management Compatibility

  • Start the Server Manager (Right-click on Computer in the start-menu or the Computer desktop icon if running classic start-menu and select Manage).
  • Right-click Roles and click Add roles.
  • In the dialogue that opens up click Next and then select Web Server (IIS).

  • In the dialogue that follows click Add Required Features.

  • Click Next (twice).
  • On the select Role services page select ASP.net.

  • In the dialogue window that appears click Add Required Role Services.
  • Click on "Add roles" and then "next" in the dialogue window that opens. Scroll down to "IIS 6 Management Compatibility", check the box and follow the rest of the installation wizard.

2. Install TAC Vista Server

3. As administrator, Run the ASP.NET IIS Registration Tool (Aspnet_regiis.exe) for ASP.NET version 2.0

  • Run the command prompt as administrator and type in the following:
  • %SystemRoot%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

4. Install TAC Vista Webstation

5. As administrator, Migrate the ASP.NET application configuration to IIS7

  • Run the command prompt as administrator and type in the following:
  • %SystemRoot%\System32\inetsrv\appcmd migrate config "Default Web Site/"

6. Change the Application Pool in IIS7

  • Go to the Webstation/ScreenMate settings in IIS.
  • Select "Advanced settings" under "Manage Application".
  • Change Application Pool" from "DefaultAppPool" to "Classic .NET AppPool".

7. Change the application pool identity

  • Locate the Application Pools in IIS
  • Locate the "Classic .NET AppPool" application Pool
  • Right-click on it and select "Advanced settings".
  • Locate the Identity attribute and set it to "Local System".