Issue
A VAS Client has been configured with low-level access for use at a security desk in a building. Only certain alarms are routed to this client and the user account assigned allows for the ability to view and acknowledge alarms. The Security Mask settings are illustrated below:
However, these settings do not allow for acknowledged alarms to be deleted from the VAS Client's Alarm History:
Environment
Niagara R2 Enterprise Server; build r2.301.529 was tested.
Niagara R2 Vykon Alarm Service (VAS) Client; version 2.5 was tested.
Cause
The VAS Client requires access to the entire alarm history database in order for the ability to delete acknowledged alarms.
Resolution
To give access to the entire alarm history database, the Security Mask settings must be modified as illustrated below:
Note: These settings will route all alarms to the specific VAS Client.
As a result, the user will be able to view, acknowledge, and delete any alarms.
There is no way to avoid this scenario. If alarm deletions are to be reserved for an administrative user, then restore the Security Mask settings as per the illustration in the Issue section of this article.