Issue
The error messages "Cannot open admin session.java.lang.NullPointerException" is displayed when attempting to open the WorkPlace Pro Admin Tool
Environment
R2, WorkPlace Pro (all versions)
Cause
Both R2 and G3 are on the same PC. Niagara G3 was last run on the PC. Error is caused by the failure to run R2 "Install Niagarad" after running G3. The G3 service stays active even after G3 is closed and will continue to be active until R2 "Install Niagarad" is run.
Resolution
"Install Niagarad" must be run when switching from the G3, WorkBench to R2, WorkPlace Pro.
- Close all versions of Workplace Pro
- Click the Start button then click All Programs
- Select the Niagara R2 release to start then click "Install Niagarad"
The Admin Tool can now be opened.