Issue
Continuum Add-On Reports will not launch
Environment
- Continuum
- Continuum Add-On Report Suite
- Windows XP
- Windows Vista
- Windows 7
- Windows Server 2003
- Windows Server 2008
Cause
The reports may not launch because of configuration issues or because the Workstation Instance in the database is corrupt.
Resolution
- Ensure that Continuum Reports is installed in Add/Remove programs
- Check that the Programs are listed under the workstation after importing the Continuum_Reports.dmp file and that they contain the reports programming code. If they are empty, re-import or cut and paste the code from the dmp file and correct errors.
- Check that the programs are enabled, if not enable the report and try again.
- Test the report from the command line instead of launching from a button (Ex. Run Reports_Suite).
- The second to last line is a Shell command, check that the Reports.exe 0 ( the number represents each report) has a unique number. Reports_Suite=0, Alarms_Report=2. A duplicated number may not run correctly.
-
As a last test, create a new program called TestCalc with the following one line of code:
Shell "C:\Windows\System32\Calc.exe"
Fall Thru, AutoStart=False
Run TestCalc from the command line and the Windows Calculator should show.
Usually if you are at this point, it will not start. If that is the case do the following to correct this.
- Get a database backup
- Go offline Edit
- Export everything under the Cyberstation to a text (dmp) file and verify it's contents.
- Delete the Cyberstation and it's folder
- Exit Cyber (You will get an error that it cannot find the object in the database - click OK)
- Open Database Initialization and select Workstation and re-initialize the WS
- Create TestCalc as mentioned above and verify that Calculator opens (It should)
- Go offline edit and import the .dmp file that had been created for this Workstation and verify all is working.
Note: If this is on a 64 bit system, the path may need to be changed.
reset_password.bat
However, if you did not install Continuum Reports in the default directory, you must edit the Reset_Password.bat file and include the DOS installation path after “password” in the run string.
ie: reports reset password D:\Reports