Issue
When attempting to run the WorkPlace Commissioning Tool using the BACnet-IP or BACnet-Ethernet protocols, the search stops immediately and the "sweeping flashlight" is not displayed. No BACnet devices are found.
Environment
Windows 7 Professional operating system
WorkPlace Tech Tool software version 5.7.4 through 5.7.7 and 5.8
Cause
The WinPcap ethernet communications driver could not be started causing the network search to fail silently.
During the installation of the WinPcap software, the installer presents an option to start the WinPcap driver at boot time. Due to potential security concerns, it is suggested that this driver be configured not to start automatically when the computer is booted. When the WinPcap driver has been installed in this mode and the user does not have system administrative rights, the driver cannot be started automatically when needed. This issue and the required actions were documented in the WorkPlace Tech Tool 5.7.4 and 5.7.5 release notes.
Resolution
As published in the release notes document, there are two different ways the issue can be handled.
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Turn off Windows U.A.C. (Not recommended for security conscious users)
- Open the Windows control panel and select User Accounts. If the control panel display is organized in the "Category" view mode, select "Add or Remove user accounts" then select the "Go to the main User Accounts page" link.
- Select "Change User Account Control Settings".
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Drag the displayed slider to the bottom position, "Never notify" then click [OK] to save the setting and exit.
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Configure the three WorkPlace Tech Tool programs to run with administrative rights. (May not be allowed on some customer owned computers). NOTE: When the WorkPlace Tech Tool programs have been configured in this manner, the User Account Control screen stating "Do you want to allow the following program to make changes to this computer" will be displayed each time one of these programs is run. It is necessary to click the [Yes] button to allow the program to run.
- From the Windows start menu or from the desktop select "Computer".
- Navigate to the folder "\Program Files\WorkPlace Tech" on the local disk C: (or the local disk where the WorkPlace Tech Tool software was installed.
- Right-click on the application WPCT (may be shown as WPCT.exe) and select Properties from the displayed list. Click on the "Compatibility" tab then click the button [Change settings for all users]. In the "Privilege Level" section, check the box "Run this program as administrator". Click [OK] to save the change and close the "All Users" compatibility options window. Click the [OK] button to close the properties window.
- Right-click on the application WPFB (may be shown as WPFB.exe) and select Properties from the displayed list. Click on the "Compatibility" tab then click the button [Change settings for all users]. In the "Privilege Level" section, check the box "Run this program as administrator". Click [OK] to save the change and close the "All Users" compatibility options window. Click the [OK] button to close the properties window.
- Right-click on the application WPTech (may be shown as WPTech.exe) and select Properties from the displayed list. Click on the "Compatibility" tab then click the button [Change settings for all users]. In the "Privilege Level" section, check the box "Run this program as administrator". Click [OK] to save the change and close the "All Users" compatibility options window. Click the [OK] button to close the properties window.
- Close the Windows explorer window.
In the event that a customer's security policy prohibits either of these methods of security permission control, the alternative is to uninstall the WinPcap program and reinstall it (by running the WorkPlace Tech Tool installer), configuring WinPcap to start automatically when the computer is booted.