Sigma - Editing objects on a Windows 7 PC is very slow and the Object file shows zero bytes.

Issue

The editing of Sigma objects is not working correctly on a Windows 7 PC.

Product Line

Satchwell Sigma

Environment

Sigma

Objects

Editing

Windows 7

Object File

0 Bytes

Cause

This was caused by a mis-configuration of the Sigma server on the Windows 7 PC, which had been set as a remote client.

Resolution

The original fault was described as shown below.

On the newly upgraded Sigma 4.04 to 4.05 SEB system, I have encountered some problems regarding Object Editing. When finishing editing, it takes a long time for the download to finish and afterwards the object file shows that it is zero bytes. If I try to edit without uploading and downloading the same happens.

The issue was traced to the configuration of the Sigma server which is set in C:\Sigma|Bin\SetupSvr.exe. This had been set for a remote Sigma client.

Local Sigma client. (Client is running on the same PC as the Sigma server).

Running SetupSvr.exe produces the following window. The window shows the configuration set for a newly installed system, which is assumed to be a local Sigma client.

Remote Sigma client. (Client is running on a different PC to that of the Sigma server).

Running SetupSvr.exe produces the following window. If the tick in the "This Computer" selection is removed, then the configuration is ready for use with a remote Sigma client. In the screen shot below, the IP address of the Sigma server has been entered, but PC names can also be used.