Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support Services for assistance.
Issue
Getting error inserting a row in the database when refreshing a personnel template.
Product Line
Andover Continuum
Environment
CyberStation
Cause
AreaLink table contains NULL instead of zero in the ClearanceLevel column.
Resolution
WARNING: Unless knowing exactly what you are doing, deleting entries from your database can cause irreversible harm to your database and can potential cause corruption. Make sure to perform a full SQL Database backup before attempting to make any changes to the database. (See Move / Backup / Restore a database on a Single User SQL2005 Express system for details on how to backup your database and if not already installed, where to get Management Studio from)
Run the following query:
Update AreaLink Set ClearanceLevel = 0 where ClearanceLevel is null