Webclient launch from a URL gets an error 'Failed to access IIS metabase'

Issue

On a new install an error is received when launching webclient using the URL. The error is 'Failed to access IIS metabase' Read access error.

Product Line

Andover Continuum

Environment

  • Webclient
  • Windows XP
  • Windows Vista
  • Windows Server 2003
  • Windows Server 2008

Cause

The .Net installation connection to IIS was made properly or the .net installation has been corrupted. 

Resolution

  1. Register the .Net Framework on the webclient PC
    1. From a DOS prompt (Start>Run cmd+enter)
    2. Cd\Windows\Microsoft.net\framework\v2.0.50727 (this places you in the correct folder)
    3. Run aspnet_regiis.exe -i (This command re-registers the .net framework with IIS)
    4. Restart IIS (Right click on default web site in IIS Manager, select stop the start)
    5. Re-test
  2. Uninstall/Reinstall .Net on the webclient PC
    If the first step doesn't correct the issue then do the following
    1. Remove the versions of .net that you can from Windows Control Panel>Add/remove programs (Try one at a time 4.0, 3.5,etc) There are dependencies when uninstalling some .net versions, so you may need an uninstall tool from the following web site: (Use at your own risk - please read the information first) http://blogs.msdn.com/b/astebner/archive/2006/05/30/611355.aspx  
    2. Install .Net framework 20 using the following file provided on the webclient installation (C:\program files\webserver\redist\dotnetfx20.exe)
    3. Restart IIS (Right click on default web site in IIS Manager, select stop the start 
    4. Re-test