How do I determine which version of the VAS client is needed to update a site?

Issue

The current version of the VAS client cannot query for records for years beyond 2010. There are two versions of the VAS Client upgrade on The Exchange Download Center. How do I determine which version of the VAS client is needed to update a site?

Product Line

TAC I/A Series

Environment

I/A Series R2 Enterprise Server
Vykon Alarm Service Client 2.4x
Vykon Alarm Service Client  3.xx

Cause

The Query Wizard in the VAS 2.4 system could not query record dates beyond 2010.

Resolution

VAS Client 2.50 -- The VAS_2.50_Client.zip file contains the VAS 2.50 Client Installer and associated Enterprise Server vas service module (vas-2.301.532.v2.jar). VAS 2.50 is for use with Enterprise Servers that utilize database management systems including Cloudscape, MSDE, Microsoft SQL, or Oracle. If currently using VAS 2.4x, upgrade to vas-2.301.532.v2 jar and VAS 2.50 client. If currently using VAS 3.xx, do not install this version. Download and upgrade to vas-2.301.532.v3.jar and VAS 3.92 client.

VAS Client 3.92 -- The VAS_3.92_Client.zip file contains the VAS 3.92 Client Installer and associated Enterprise Server vas service module (vas-2.301.532.v3.jar). VAS 3.92 is for use with Enterprise Servers that utilize MSDE, Microsoft SQL, or Oracle database management systems only. VAS 3.92 Is not compatible with Cloudscape. If currently using VAS 3.xx, upgrade to vas-2.301.532.v3 jar and VAS 3.92 client. If currently using VAS 2.4x, do not install this version. Download and upgrade to vas-2.301.532.v2.jar and VAS 2.50 client.