Continuum Analyzer Description

Issue

There is a need to understand what the Continuum Analyzer does

Product Line

Andover Continuum

Environment

Continuum Analyzer

Windows 7

Windows 2003

Windows Server 2008

Cause

There is a description of what the Continuum Analyzer does on the service release CD, but it will be handy do have it in Lessons Learned

Resolution

The Continuum Analyzer description and what it does is in the service release CD. It is listed here in this Lessons Learned article for convenience.

The Continuum Analyzer is designed to provide installers and troubleshooters with a point of reference for discovering problem areas within their installations.  The software is proactive in that it enables you to 'clean' orphaned and mismatched objects from the database, thereby recovering from a minimal amount of database corruption.  Continuum Analyzer also performs a system information check and provides full reporting on all aspects of the installation, as well as alerts regarding deficiencies.

This article is provided to you as a guideline and an operational reference for use of the Continuum Analyzer.  It is of the utmost importance that you review the current, Continuum Cyberstation Release Notes, before using this product.  This document refers to specific changes made to the operation of the Cyberstation software in its new release.

Installation Requirements

Continuum Cyberstation software must also be installed on the given computer, and meet its hardware and software specifications as detailed in the, Continuum Getting Started Guide.

Uninstall Previous Analyzer Versions

If a previous revision of Continuum Analyzer is installed on the computer, it is important to remove it before installing a newer version.  This is easily accomplished using the following procedure.

1. Close all open applications before proceeding.

2. Select Start, then Settings, and then Control Panel.

3. Once inside the Control Panel, select the Add/Remove Software icon and select, Continuum Analyzer.

4. When prompted, select Yes to remove all application components, and Remove All once uninstall begins.

5. Close the Add/Remove applet and reboot your system.  You may now proceed with installation of a newer version, below.

Setup Procedure

1. Close all open applications before proceeding.

2. Setup will begin unpacking necessary files.  Older versions of Windows workstation may require system   file upgrades.  An alert message will display asking

you to confirm this operation.  You may be required to reboot your computer.  If this is the case, rerun setup after the computer restarts.

3. The installation awareness screen prompts you for the location in which the files are installed.  We recommend allowing the default installation directory. 

(C:\Program Files\Continuum\ContinuumUtilities\Continuum_Analyzer)  When you are satisfied with the location, click on the large installation icon towards the left of the dialogue box.  Figure One, below, details this screen.

4. When prompted for creation of the program group in which the Analyzer will reside, select the default, or choose an existing program group for these icons.

5. Setup will copy the necessary files into the installation directory on the hard drive.

6. When finished, you are prompted that setup is complete and need to click, OK to verify.

7. Setup is complete.

Operation Modes
Continuum Cyberstation software allows the user to define the type of database used to house the system information.  Typical system configurations rely on the implementation of Microsoft SQL Server.
 
LAN Mode
This operating mode provides the user with all available information about the system installation, including SQL parameters used on the database server.    This additional information can help reconcile issues that exist within the configuration of the SQL server. 
 
Stand Alone
This mode diagnoses problems and lends the equivalent information presented through SQL implementation.  
 
Password Confirmation
Continuum Analyzer requires the user to enter a password before launching the GUI.  The password used should match the password of the SQL account used by Continuum.  If all installation defaults were followed, the password is, pyramid97.
 
Navigating the Interface
The Analyzer uses an intuitive interface to easily collect and return data from Continuum installations. The interface is broken into 5 parts; a function toolbar, system toolbar, status prompt, report explorer, and the report window.  Appendix B contains a screen shot of the analyzer display.  Several toolbars located throughout the graphical interface permit point and click operation of the software.
 
Function Toolbar
This toolbar is located to the upper-left hand side of the Analyzer interface. 
Each toolbar feature is explained below.  Button descriptions will also appear
When the mouse is held idle over the selected feature.
 
Save Reports to File
Activating this button saves the Main and Suspect generated report to a *.csv file at the location specified by the user. The Save dialogue box prompts the user for the report destination.  This file is required for proper technical support from Andover Controls Corp.
 
Word Wrap
This button wraps each line of output data to fit within the parameters of the display window.
 
Run
Begins data collection on the system.
 
Clean
The clean button removes references to suspect objects found during the initial database screening.  After the items are removed from the database, the analyzer is automatically rerun to ensure that no remaining corruption exists.
 
System Toolbar
The System Toolbar features shortcuts to many of the same features as the Function Toolbar.  This feature group also contains a button to close the program and a display window that monitors the integrity of the database and indicates corruption when found.
Operation Modes
Continuum Cyberstation software allows the user to define the type of database used to house the system information.  Typical system configurations rely on the implementation of Microsoft SQL Server.
 
LAN Mode
This operating mode provides the user with all available information about the system installation, including SQL parameters used on the database server.    This additional information can help reconcile issues that exist within the configuration of the SQL server. 
 
Stand Alone
This mode diagnoses problems and lends the equivalent information presented through SQL implementation.  
 
Password Confirmation
Continuum Analyzer requires the user to enter a password before launching the GUI.  The password used should match the password of the SQL account used by Continuum.  If all installation defaults were followed, the password is, pyramid97.
 
Navigating the Interface
The Analyzer uses an intuitive interface to easily collect and return data from Continuum installations. The interface is broken into 5 parts; a function toolbar, system toolbar, status prompt, report explorer, and the report window.  Appendix B contains a screen shot of the analyzer display.  Several toolbars located throughout the graphical interface permit point and click operation of the software.
 
Function Toolbar
This toolbar is located to the upper-left hand side of the Analyzer interface. 
Each toolbar feature is explained below.  Button descriptions will also appear
When the mouse is held idle over the selected feature.
 
Save Reports to File
Activating this button saves the Main and Suspect generated report to a *.csv file at the location specified by the user. The Save dialogue box prompts the user for the report destination.  This file is required for proper technical support from Andover Controls Corp.
 
Word Wrap
This button wraps each line of output data to fit within the parameters of the display window.
 
Run
Begins data collection on the system.
 
Clean
The clean button removes references to suspect objects found during the initial database screening.  After the items are removed from the database, the analyzer is automatically rerun to ensure that no remaining corruption exists.
 
System Toolbar
The System Toolbar features shortcuts to many of the same features as the Function Toolbar.  This feature group also contains a button to close the program and a display window that monitors the integrity of the database and indicates corruption when found.
 
Status Prompt
The analyzer status prompt displays the progress of a current session. During an active session, the status indicator bar will fill to indicate that the analyzer has completed its review of the system.  It may take Analyzer several minutes to complete its system scan.  The status bar is located in the center of the system toolbar.  Please refer to figure four for a detail of the system toolbar and status prompt.
 
Log Selection Windows
Analyzer allows a technician to specify log collection dates independently for both the Error and Activity logs using calendar menus as detailed below. 
 
This feature is helpful in reducing the amount of time necessary for the completion of an Analyzer scan, and identifying the point at which problems first occurred.  The user may choose not to report on log collection by selecting one day ahead of the present date.
 
Report Explorer Navigation
The report explorer allows navigation through each report feature in a manner akin to the windows explorer file manager found in Windows.  Navigate by double clicking on the desired report folder and selecting the appropriate report from the file list.  Figure Seven details the report explorer below. 
 
The root of the Analyzer’s report explorer indicates to the user the mode in which the analyzer is running (LAN Mode or Stand Alone.)  Each folder displayed below the root contains a report(s) on the system.
 
Continuum Logs
These log reports display two kinds of activity.  The first report, Continuum Activity, displays all system user actions on the system during the period specified in the calendar selection window.  The second report, Continuum Errors, shows the continuum error log during the dates specified within the parameters of the calendar selection window.
 
Cyberstations
This report area displays each workstation’s properties as detailed by the device table, and all Plain English programs that are installed at each workstation.
 
Database Integrity
This report allows a technician the ability to quickly identify an area of data corruption within the various link tables of the Continuum database.  Each of the following reports specifies the type of link verified and a numeric display of how many broken links appear within the system.  Typically, broken links detected by Continuum Analyzer can be cleaned from the system, using the clean feature.  The clean feature removes all references to the orphaned item.
 
Distributions
Pending and failed distributions are monitored from within this report area.  Failed distributions detail the name of the object and its status.  The Pending distributions monitor the type, content, and numeric statistic of distributions waiting to complete.
 
Field Devices
Field device reports detect the variable parameters for different classes of objects configured in the field.  This gives the technician a holistic reference point for determining any conflicting parameters within the system. Please refer below for information regarding the content of each report.
This feature is helpful in reducing the amount of time necessary for the completion of an Analyzer scan, and identifying the point at which problems first occurred.  The user may choose not to report on log collection by selecting one day ahead of the present date.
 
Report Explorer Navigation
The report explorer allows navigation through each report feature in a manner akin to the windows explorer file manager found in Windows.  Navigate by double clicking on the desired report folder and selecting the appropriate report from the file list.  Figure Seven details the report explorer below. 
 
The root of the Analyzer’s report explorer indicates to the user the mode in which the analyzer is running (LAN Mode or Stand Alone.)  Each folder displayed below the root contains a report(s) on the system.
 
Continuum Logs
These log reports display two kinds of activity.  The first report, Continuum Activity, displays all system user actions on the system during the period specified in the calendar selection window.  The second report, Continuum Errors, shows the continuum error log during the dates specified within the parameters of the calendar selection window.
 
Cyberstations
This report area displays each workstation’s properties as detailed by the device table, and all Plain English programs that are installed at each workstation.
 
Database Integrity
This report allows a technician the ability to quickly identify an area of data corruption within the various link tables of the Continuum database.  Each of the following reports specifies the type of link verified and a numeric display of how many broken links appear within the system.  Typically, broken links detected by Continuum Analyzer can be cleaned from the system, using the clean feature.  The clean feature removes all references to the orphaned item.
 
Distributions
Pending and failed distributions are monitored from within this report area.  Failed distributions detail the name of the object and its status.  The Pending distributions monitor the type, content, and numeric statistic of distributions waiting to complete.
 
Field Devices
Field device reports detect the variable parameters for different classes of objects configured in the field.  This gives the technician a holistic reference point for determining any conflicting parameters within the system. Please refer below for information regarding the content of each report.
 
Report Name                                       Description
CommPorts                                         Infinity Controller 
                                                               communication port 
                                                               configurations
InfinityControllers                               CX controller parameters
InfinityInfinetControllers                     Defined parameters for infinet devices
InfinityPrograms                                  Details programs that reside on the CX controllers
IOU Modules                                        Parameters for each IOU configured within the system
Networks                                              Network Object parameters
 
Each field device report displays values as an enumeration from within the database.  Troubleshooting with the Analyzer requires that a technician be able to correlate each reported value of an attribute to the software value that Continuum displays within the object editor.  Please refer to Appendix A for a definition and value range for variables discussed in the reports.
 
General Continuum
These detail all Continuum installation parameters, providing the technician with the ability to troubleshoot any problems that might occur at the software installation level.  Aspects covered in this report segment include ODBC client connector details, connection status, domain user account information, and installation path.
 
Workstation
Workstation reports provide system information on the workstation hardware and operating system configuration.  These reports help clarify any Continuum software compliance issues.
 
SQL Server
SQL Configuration information is provided through two reports, Database Configuration and Server Configuration.  These values are used to trace possible problems back to a server configuration variable.
 
Summary Report
The summary report issues system details that provide a quick overview of the Continuum configuration in use at a particular facility.  One set of data in particular is worth discussion, as the values here can lead to problems with the workstation performance of the system. 
 
The summary includes a section labeled Windows Registry Check.  If the software installation was performed correctly, registry keys will be entered in the Local Machine hive of the registry.  It is possible under abnormal installation circumstances that these registry entries are placed under the Current User hive. 
 
The Analyzer retrieves these registry values and displays them as follows in figure eight.  If the machine is properly configured, the values will only display once, to the right side of the definition text. This indicates their presence in the appropriate location. 
 
If the values are located on the left-hand side of the definition text, the installation did not put the appropriate values in the correct location.  
 
Suspect Objects
The suspect object report details three categories of data corruption detected within the database.  If data corruption is discovered, the system toolbar and the report explorer will indicate such.  The first category, Suspect Objects Correctable, contains any corrupt data that the Analyzer can repair using the clean command.  Suspect Objects  Manual Fix details configuration issues which require manually editing the erroneous variable.  The final category, Suspect Objects  Uncorrectable requires the assistance of Andover Controls TSD staff to remedy the problems.  Please be aware that support for these issues requires that ACC TSD staff have a copy of the Analyzer report from the system in question. 
 
Figure nine details the report explorer icon displayed when corruption is detected.  It is recommended that all suspect objects are saved as a file to aid in recreating the broken link objects.  The Clean button is used after the Save Suspect Objects to File button to remove the broken objects from the database.
 
Analyzer Report
This report details all areas of data collection and is saved in a *.csv format.  You may save a report in one of the following ways.
 
Saving your Analyzer Reports
The Continuum Analyzer generates two reports that can be saved for review.  Both reports can be saved simultaneously, or individually using the reports menu option at the top of the Analyzer window.
 
Suspect Objects Report
The suspect object report is optionally generated when data corruption is discovered.  If you do not see the visual indicators that suspect objects are present in the system, then there is no report to generate.  However, if corruption is present, the report must be saved.
 
 
All Cyberstation Workstations
Invoke the analyzer by selecting the Continuum Analyzer icon from the Start Menu.  You are prompted for a password.  This password is the same as the password used to access your database from the ODBC connector.  Figure Ten displays the password dialog box.  If Continuum was installed with the default options, the database login password is Pyramid97.
 
You may change the start date for log collection through the calendar menu, if necessary. Select, “Run” to begin analysis.  The program will run for several seconds, an active display in the system toolbar details its progress.  Save the report generated by each machine.
 
Repair Data Corruption
 
IMPORTANT! 
 
Note that this is option is NOT always available!
 
If the Continuum Analyzer reports that data corruption was found, a stop sign icon appears in the report explorer and a Database Integrity Failed message appears at the top of the system toolbar.  Select the option button labeled, Save Suspect Objects to File.   Upon completion, select the Clean option.  You’ll notice that after this button is selected, the database is cleaned and the Analyzer is run a second time, to ensure there is no remaining corruption within the database. 
 
Submit Analyzer Report
The Continuum Analyzer Reports should be sent to our technical support department before upgrading if uncorrectable errors were found.  Schneider Electric has a technical support address designed for this purpose.  The email should include the following information.
Subject: /
Body:
· Dealership name
· Site Name
· File attachments: Analyzer Reports (each workstation)
· File attachments: Suspect Object Reports (each workstation)
 
This email should be sent to Product Support
 
All workstation analyzer reports and suspect object reports should be attached to a single email. 
 
Run Analyzer before Upgrade
The Analyzer must be run again prior to the upgrade installation to verify that database integrity is stable.  Using the Primary Access Server, run the analyzer, save the generated reports, and clean any suspect objects if necessary.
 
Uninstall Continuum
Make a note of the workstation and database settings within the Database Initialization Program.  Uninstall earlier versions of Continuum from the workstations through the Add/Remove Programs icon located in the Control Panel.  Select Continuum from the menu of programs and follow the automated procedure.  You must reboot after un-installing.
 
Install Continuum
Refer to the Continuum Cyberstation Getting Started Guide for installation instructions.  The first workstation upgraded should use the database initialization program to UPDATE an existing database.  Ensure that the server name and authentication information is entered correctly.  Verify that the workstation settings are IDENTICAL to those used in the previous installation of Continuum Cyberstation.
 
Rerun Continuum Analyzer
Rerun the Continuum Analyzer to verify that data within the tables is stable, and that all workstation settings are properly configured.  If database corruption is present again, we recommend contacting our Technical Support Department for further information.
 
Appendix A
 
Field Translation Guide
The Continuum Analyzer report references the exact table and column names used within the Continuum database.  This appended reference should be used when trying to correlate settings and values from the analyzer report against values within the Cyberstation software.  Please direct any further inquires to our Technical Support Department.
 
 
Field Name  Description                                                                                                     Typical Values
Autostart       autostart on/off                                                                                                True/False
 
Baud              Enumerated value starting with 0 for 300.  
                       Each rate of speed has its own enumerated value                                 0=300,1=1200,2=2400,3=4800,4=9600 and 5=19.2
            
Command     Whether a program can execute from command line                          on/off
 
DefaultBaud When a Commport is created it is assigned the                                    0=300,1=1200,2=2400,3=4800,4=9600 and 5=19.2
                       default baud of 9600 which is equal to 4
 
DefaultMode This is the mode the CommPort is configured to                                   0=Printer,2=Command,3=Infinet,5=Autoset
                        use.  i.e., Infinet, printer                                                                                6=Tanknet,11=Xdriver
            
Description  Text string entered into the object                                                               user defined
                       description field
 
DialPrefix    Standard Commport initialization settings                                                  ATDT
 
DialSuffix   Standard Commport initialization settings                                                   |013
 
DirectConnect  User selectable checkbox definition                                                      True or False.  True if checkbox is selected
 
Filesize       Size of the program file in bytes                                                                     18
 
FlowControl  UART datastream control                                                                             0=NoFlowControl, 1=XonXoff, 2=CtsRts, 
                                                                                                                                                   3=XonXoffCtsRts
 
HangUpCmd  Standard Commport termination request                                               @@@+++@@@ATH0|013
 
InfinetID          Unique Identifier assigned to infinet controllers 
 
IOU Number  reference ID attached to the current module                                            1-32
 
Location     Controller to which an object is attached                                                       User Defined
 
MaxResponse Time  Maximum amount of time to wait for a response                          Default 5 Sec
                      in seconds
 
ModelName  Value obtained from hardware                                                                     hardware/software type and version
 
ModemInit    Modem initialization string                                                                     AT&F|013@@@@@@@@@@@ATEQ1&C1&D3S1S0=1W3\J\Q3%C1&W|013
 
Module ID    Unique module identifier; hardware encoded                                            Not user Definable
                      in each module
 
NetworkID  Energy net ID for the object                                                                              1-190
 
NetworkID  Workstation's Energy Net identification number                                          1-64 are recognized by the CXs and       
                                                                                                                                                    NetController.  Ids above 64 are recognized 
                                                                                                                                                    by Workstations only.
 
NetworkUTCOffset   GMT offset of the network objects                                                   User Defined in minutes
 
Owner        Name of attached controller object                                                                  User Defined
 
Parity         Standard Commport entries                                                                               0
 
PortNum    Enumerated value of commport number to which                                        0=1, 1=2, 2-3, 3=4
                    a device is attached
 
PrimaryAccessLogger   Workstation computer designated as the                                0=Not Primary, 1=Primary
                    primary access server
 
ProbeTime  time between TTL pings
 
ProbeTime  Probe Frequency                                                                                                Default 60 Sec
 
Program ID  Internal Firmware reference ID                                                                       4th digit from the left represents IOU firmware revision
                                                             
SecondaryAccessLogger                                                                                                        0=Not Secondary, 1 = Secondary
                       Workstation computer designated as the secondary 
                       access server
 
SendToACX  Whether or not the object must be sent to the                                             0/1
                        corresponding ACX controller
 
SendToCX   Whether or not the object must be sent to the                                              0/1
                       corresponding controller
 
SerialNum    Serial number of the network controller object                                             527853
 
Shareflag      Whether program is able to run on any workstation                                    on/off
 
State               Determines whether an object is active within the                                      TRUE
                        system or not
 
StopBits         Commport initialization setting                                                                        0
 
SynchDB       Whether or not the object must be synchronized                                          0/1
                        with the database
 
TerminalType   Determines Commport emulation                                                               0=VT100, 1=VT220, 2=Wyse
 
TimeOutValue   No user definition                                                                                           0
 
TrackCxd       Changed through checkbox selection                                                             True or False.  True if checkbox is selected
 
UiName         Object name in database                                                                                  User Defined
 
UTCOffset      Number of minutes offset from GMT                                                              User Defined in minutes
 
VersionNum   Firmware revision number                                                                               Ex. 1.53x, 1.2x, 2.1x, 4.5x
 
XDriverFile       Location of and name of any Xdriver assigned                                           User Defined
                          to the port